ユーザ用ツール

サイト用ツール


11_php:02_framework:01_symfony

差分

この文書の現在のバージョンと選択したバージョンの差分を表示します。

この比較画面にリンクする

両方とも前のリビジョン 前のリビジョン
11_php:02_framework:01_symfony [2014/07/03 13:39]
matsui 11_php:フレームワーク:01_symfony renamed to 11_php:02_framework:01_symfony
11_php:02_framework:01_symfony [2014/08/07 11:19] (現在)
matsui [php 5.3.3へアップデート]
ライン 1: ライン 1:
 +====== 01 Symfony ======
  
 +<code console>
 +$ cat composer.json ​
 +{
 +    "​require":​ {
 +        "​symfony/​symfony":​ "​2.1.*"​
 +    }
 +}
 +</​code>​
 +
 +インストール
 +<code console>
 +$ php composer.phar install
 +</​code>​
 +
 +
 +===== ソースを持ってくる場合 =====
 +
 +<​code>​
 +# wget http://​symfony.com/​download?​v=Symfony_Standard_Vendors_2.1.7.tgz
 +# tar zxvf Symfony_Standard_Vendors_2.1.7.tgz
 +# cd Symfony
 +</​code>​
 +
 +-チェックコマンド
 +<​code>​
 +# php app/​check.php ​
 +</​code>​
 +
 +===== php 5.3.3へアップデート =====
 +
 +
 +[[01_linux:​02_www:​81_php53-common_conflicts_with_php-common|]]
 +===== タイムゾーン設定 =====
 +<​code>​
 +# vi /​etc/​php.ini ​
 +date.timezone = "​Asia/​Tokyo"​
 +</​code>​
 +
 +===== その他必要なものインストール =====
 +
 +<​code>​
 +# yum install php53-xml
 +# yum install php53-pdo
 +</​code>​
11_php/02_framework/01_symfony.txt · 最終更新: 2014/08/07 11:19 by matsui

Yesterday:379 Today:512 Total:01170